Cisco复习(配置、CDP、静态、RIP、OSPF)

Standard

不用就忘,复习复习.
备份配置文件

Router>en
Router#int fa 0/0
Router#ip address 192.168.0.1 255.255.255.0
Router#no shut
Router#copy running-config tftp:
Address or name of remote host []? 192.168.0.2
Destination filename [Router-confg]? Router-config-bak-2011-7-20
 
Writing running-config...!!
[OK - 463 bytes]
 
463 bytes copied in 0.063 secs (7000 bytes/sec)
Router#

通过tftp加载配置文件

Router#copy tftp://192.168.0.2/Router-config-bak-2011-7-20 running-config
Accessing tftp://192.168.0.2/Router-config-bak-2011-7-20...
Loading Router-config-bak-2011-7-20 from 192.168.0.2: !
[OK - 463 bytes]
 
463 bytes copied in 0.031 secs (14935 bytes/sec)
Router#

Copy IOS到tftp

Router#copy flash: tftp:
Source filename []? c2800nm-advipservicesk9-mz.124-15.T1.bin
Address or name of remote host []? 192.168.0.2
Destination filename [c2800nm-advipservicesk9-mz.124-15.T1.bin]? c2800nm-advipservicesk9-mz.124-15.T1_bak.bin
 
Writing c2800nm-advipservicesk9-mz.124-15.T1.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 50938004 bytes]
 
50938004 bytes copied in 27.891 secs (1826000 bytes/sec)

使用CDP获取相连设备信息

Router>en
Router#conf t
Router(config)#hostname Router0
Router0(config)#int fa 0/0
Router0(config-if)#ip address 192.168.1.1 255.255.255.0
Router0(config-if)#no shut
 
Router>en
Router#conf t
Router(config)#hostname Router1
Router1(config)#int fa 0/0
Router1(config-if)#ip address 192.168.1.2 255.255.255.0
Router1(config-if)#no shut
Router1(config)#int fa 0/1
Router1(config-if)#ip address 192.168.2.1 255.255.255.0
Router1(config-if)#no shut
Router1(config-if)#exit
Router1(config)#show cdp neighbors
Router1#no cdp run
Router1#cdp run
 
Switch>en
Switch#conf t
Switch(config)#hostname Switch0
Switch0(config)#int fa 0/1
Switch0(config-if)#cdp enable
Switch0(config-if)#no cdp enable
Switch0(config-if)#cdp enable

禁用域名解析

Router0>en
Router0#conf t
Router0(config)#no ip domain-lookup
Router0(config)#end
Router0#

静态路由

Router0#conf t
Router0(config)#ip route 192.168.4.0 255.255.255.0 192.168.2.2
 
Router1#conf t
Router1(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
Router1(config)#ip route 192.168.4.0 255.255.255.0 192.168.3.2
 
Router2#conf t
Router2(config)#ip route 192.168.1.0 255.255.255.0 192.168.3.1
//PC0 ping 192.168.4.1 ok
//PC0 ping 192.168.3.1 unreachable
//PC1 ping 192.168.1.1 ok
//PC1 ping 192.168.2.1 unreachable
 
Router0(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2
//PC0 ping 192.168.3.1 ok
Router2(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.2
//PC1 ping 192.168.2.1 ok

RIP

Router1#conf t
Router1(config)#int se 1/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config)#int se 1/1
Router1(config-if)#ip address 10.3.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1#show interfaces serial 1/0
Serial1/1 is up, line protocol is up (connected)
...
Router1#show interfaces serial 1/1
Serial1/1 is up, line protocol is up (connected)
...
 
Router2#conf t
Router2(config)#int se 1/0
Router2(config-if)#ip address 192.168.1.2 255.255.255.0
Router2(config)#int fa 0/0
Router2(config-if)#ip address 192.168.3.1 255.255.255.0
 
Router3#conf t
Router3(config)#int se 1/1
Router3(config-if)#ip address 10.3.1.2 255.255.255.0
Router3(config)#int fa 0/0
Router3(config-if)#ip address 10.3.3.1 255.255.255.0
 
Router1(config)#router rip
Router1(config-router)#network 192.168.1.0
Router1(config-router)#network 10.3.1.0
 
Router2(config)#router rip
Router2(config-router)#network 192.168.1.0
Router2(config-router)#network 192.168.3.0
 
Router3(config)#router rip
Router3(config-router)#network 10.3.1.0
Router3(config-router)#network 10.3.3.0
 
Router1#debug ip rip
RIP protocol debugging is on
Router1#RIP: received v2 update from 10.3.1.2 on Serial1/1
      10.3.3.0/24 via 0.0.0.0 in 1 hops
      ...
 
Router1#show ip route
...
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.1.0 is directly connected, Serial1/1
R       10.3.3.0 [120/1] via 10.3.1.2, 00:00:08, Serial1/1
C    192.168.1.0/24 is directly connected, Serial1/0
R    192.168.3.0/24 [120/1] via 192.168.1.2, 00:00:15, Serial1/0
 
PC0>tracert 10.3.3.2
Tracing route to 10.3.3.2 over a maximum of 30 hops:
  1   62 ms     32 ms     31 ms     192.168.3.1
  2   62 ms     62 ms     63 ms     192.168.1.1
  3   78 ms     94 ms     94 ms     10.3.1.2
  4   *         125 ms    125 ms    10.3.3.2
Trace complete.

OSPF

采集站请慢,还没写完呢,有空再加…

转载请注明出处:http://yemaosheng.com

Linux系统常用信息查看命令

Standard

系统
# uname -a # 查看内核/操作系统/CPU信息
# head -n 1 /etc/issue # 查看操作系统版本
# cat /proc/cpuinfo # 查看CPU信息
# hostname # 查看计算机名
# lspci -tv # 列出所有PCI设备
# lsusb -tv # 列出所有USB设备
# lsmod # 列出加载的内核模块
# env # 查看环境变量

资源
# free -m # 查看内存使用量和交换区使用量
# df -h # 查看各分区使用情况
# du -sh <目录名> # 查看指定目录的大小
# grep MemTotal /proc/meminfo # 查看内存总量
# grep MemFree /proc/meminfo # 查看空闲内存量
# uptime # 查看系统运行时间、用户数、负载
# cat /proc/loadavg # 查看系统负载

磁盘和分区
# mount | column -t # 查看挂接的分区状态
# fdisk -l # 查看所有分区
# swapon -s # 查看所有交换分区
# hdparm -i /dev/hda # 查看磁盘参数(仅适用于IDE设备)
# dmesg | grep IDE # 查看启动时IDE设备检测状况

网络
# ifconfig # 查看所有网络接口的属性
# iptables -L # 查看防火墙设置
# route -n # 查看路由表
# netstat -lntp # 查看所有监听端口
# netstat -antp # 查看所有已经建立的连接
# netstat -s # 查看网络统计信息

进程
# ps -ef # 查看所有进程
# top # 实时显示进程状态

用户
# w # 查看活动用户
# id <用户名> # 查看指定用户信息
# last # 查看用户登录日志
# cut -d: -f1 /etc/passwd # 查看系统所有用户
# cut -d: -f1 /etc/group # 查看系统所有组
# crontab -l # 查看当前用户的计划任务

服务
# chkconfig –list # 列出所有系统服务
# chkconfig –list | grep on # 列出所有启动的系统服务

程序
# rpm -qa # 查看所有安装的软件包

另外这里还有些命令

history命令技巧

Standard

查看命令历史的时间戳
export HISTTIMEFORMAT=’%F %T ‘
history

2008-12-11 18:01:22 service iptables start
2008-12-11 18:01:36 service mysqld start

清除所有命令历史
history -c

忽略特定命令
export HISTIGNORE=”pwd:ls:ll:”

我的~/.bash_profile

HISTSIZE=9999
HISTFILESIZE=9999
HISTFILE=/root/.history
export HISTTIMEFORMAT='%F %T '
export HISTCONTROL=ignoredups
export HISTIGNORE="ll:ls"

Linux IP命令教程

Standard

鄙视采集器-_- 本来满好的一遍文章,结果弄得整个google上面全是格式排版面目全非的采集内容,原文出处反而找都找不着-_- 这里重新缩进排版转载一下以便自己查找使用.

首先,先了解传统的网络配置命令:
1. 使用ifconfig命令配置并查看网络接口情况
  示例1: 配置eth0的IP,同时激活设备:
     # ifconfig eth0 192.168.4.1 netmask 255.255.255.0 up
  示例2: 配置eth0别名设备 eth0:1 的IP,并添加路由
    # ifconfig eth0:1 192.168.4.2
    # route add –host 192.168.4.2 dev eth0:1
  示例3:激活(禁用)设备
    # ifconfig eth0:1 up(down)
  示例4:查看所有(指定)网络接口配置
    # ifconfig (eth0)
—————————
2. 使用route 命令配置路由表
   示例1:添加到主机路由
    # route add –host 192.168.4.2 dev eth0:1
    # route add –host 192.168.4.1 gw 192.168.4.250
   示例2:添加到网络的路由
    # route add –net IP netmask MASK eth0
    # route add –net IP netmask MASK gw IP
    # route add –net IP/24 eth1
   示例3:添加默认网关
    # route add default gw IP
   示例4:删除路由
    # route del –host 192.168.4.1 dev eth0:1
   示例5:查看路由信息
    # route 或  route -n  (-n 表示不解析名字,列出速度会比route 快)
—————————
3.ARP 管理命令
   示例1:查看ARP缓存
    # arp
   示例2: 添加
    # arp –s IP MAC
   示例3: 删除
    # arp –d IP
—————————
4. ip是iproute2软件包里面的一个强大的网络配置工具,它能够替代一些传统的网络管理工具。例如:ifconfig、route等,
  上面的示例完全可以用下面的ip命令实现,而且ip命令可以实现更多的功能.下面介绍一些示例:
 
4.0 ip命令的语法
  ip [OPTIONS] OBJECT [COMMAND [ARGUMENTS]]

4.1 ip link set–改变设备的属性. 缩写:set、s
  
   示例1:up/down 起动/关闭设备。
      # ip link set dev eth0 up
      这个等于传统的 # ifconfig eth0 up(down)
   示例2:改变设备传输队列的长度。
      参数:txqueuelen NUMBER或者txqlen NUMBER
      # ip link set dev eth0 txqueuelen 100
   示例3:改变网络设备MTU(最大传输单元)的值。
      # ip link set dev eth0 mtu 1500
   示例4: 修改网络设备的MAC地址。
      参数: address LLADDRESS
      # ip link set dev eth0 address 00:01:4f:00:15:f1

4.2 ip link show–显示设备属性.  缩写:show、list、lst、sh、ls、l
  -s选项出现两次或者更多次,ip会输出更为详细的错误信息统计。
  示例:
  # ip -s -s link ls eth0
  这个命令等于传统的 ifconfig eth0
—————————
5.1 ip address add–添加一个新的协议地址. 缩写:add、a
   示例1:为每个地址设置一个字符串作为标签。为了和Linux-2.0的网络别名兼容,这个字符串必须以设备名开头,接着一个冒号,
    # ip addr add local 192.168.4.1/28 brd + label eth0:1 dev eth0
   示例2: 在以太网接口eth0上增加一个地址192.168.20.0,掩码长度为24位(155.155.155.0),标准广播地址,标签为eth0:Alias:
    # ip addr add 192.168.4.2/24 brd + dev eth1 label eth1:1
这个命令等于传统的: ifconfig eth1:1 192.168.4.2

5.2 ip address delete–删除一个协议地址. 缩写:delete、del、d
    # ip addr del 192.168.4.1/24 brd + dev eth0 label eth0:Alias1

5.3 ip address show–显示协议地址. 缩写:show、list、lst、sh、ls、l
    # ip addr ls eth0

5.4.ip address flush–清除协议地址. 缩写:flush、f
   示例1 : 删除属于私网10.0.0.0/8的所有地址:
   # ip -s -s a f to 10/8
   示例2 : 取消所有以太网卡的IP地址
   # ip -4 addr flush label “eth0”
—————————
6. ip neighbour–neighbour/arp表管理命令
  缩写 neighbour、neighbor、neigh、n
  命令 add、change、replace、delete、fulsh、show(或者list)

6.1 ip neighbour add — 添加一个新的邻接条目
  ip neighbour change–修改一个现有的条目
  ip neighbour replace–替换一个已有的条目
  缩写:add、a;change、chg;replace、repl
  示例1: 在设备eth0上,为地址10.0.0.3添加一个permanent ARP条目:
  # ip neigh add 10.0.0.3 lladdr 0:0:0:0:0:1 dev eth0 nud perm
  示例2:把状态改为reachable
      # ip neigh chg 10.0.0.3 dev eth0 nud reachable

6.2.ip neighbour delete–删除一个邻接条目
  示例1:删除设备eth0上的一个ARP条目10.0.0.3
     # ip neigh del 10.0.0.3 dev eth0
6.3.ip neighbour show–显示网络邻居的信息. 缩写:show、list、sh、ls
  示例1: # ip -s n ls 193.233.7.254
     193.233.7.254. dev eth0 lladdr 00:00:0c:76:3f:85 ref 5 used 12/13/20 nud reachable
6.4.ip neighbour flush–清除邻接条目. 缩写:flush、f
   示例1: (-s 可以显示详细信息)
    # ip -s -s n f 193.233.7.254
—————————
7. 路由表管理
7.1.缩写 route、ro、r
7.5.路由表
   从Linux-2.2开始,内核把路由归纳到许多路由表中,这些表都进行了编号,编号数字的范围是1到255。另外,
   为了方便,还可以在/etc/iproute2/rt_tables中为路由表命名。
   默认情况下,所有的路由都会被插入到表main(编号254)中。在进行路由查询时,内核只使用路由表main。

7.6.ip route add — 添加新路由
  ip route change — 修改路由
  ip route replace — 替换已有的路由
  缩写:add、a;change、chg;replace、repl
   示例1: 设置到网络10.0.0/24的路由经过网关193.233.7.65
      # ip route add 10.0.0/24 via 193.233.7.65

   示例2: 修改到网络10.0.0/24的直接路由,使其经过设备dummy
      # ip route chg 10.0.0/24 dev dummy

   示例3: 实现链路负载平衡.加入缺省多路径路由,让ppp0和ppp1分担负载(注意:scope值并非必需,它只不过是告诉内核,这个路由要经过网关而不是直连的。实际上,如果你知道远程端点的地址,使用via参数来设置就更好了)。
      # ip route add default scope global nexthop dev ppp0 nexthop dev ppp1
      # ip route replace default scope global nexthop dev ppp0 nexthop dev ppp1
   示例4: 设置NAT路由。在转发来自192.203.80.144的数据包之前,先进行网络地址转换,把这个地址转换为193.233.7.83
      # ip route add nat 192.203.80.142 via 193.233.7.83

   示例5: 实现数据包级负载平衡,允许把数据包随机从多个路由发出。weight 可以设置权重.
      # ip route replace default equalize nexthop via 211.139.218.145 dev eth0 weight 1 nexthop via 211.139.218.145 dev eth1 weight 1

7.7.ip route delete– 删除路由
  缩写:delete、del、d
   示例1:删除上一节命令加入的多路径路由
     # ip route del default scope global nexthop dev ppp0 nexthop dev ppp1

7.8.ip route show — 列出路由
  缩写:show、list、sh、ls、l

   示例1: 计算使用gated/bgp协议的路由个数
     # ip route ls proto gated/bgp |wc
      1413  9891  79010

   示例2: 计算路由缓存里面的条数,由于被缓存路由的属性可能大于一行,以此需要使用-o选项
     # ip -o route ls cloned |wc
      159  2543  18707
   示例3: 列出路由表TABLEID里面的路由。缺省设置是table main。TABLEID或者是一个真正的路由表ID或者是/etc/iproute2/rt_tables文件定义的字符串,
      或者是以下的特殊值:
       all — 列出所有表的路由;
       cache — 列出路由缓存的内容。
      ip ro ls 193.233.7.82 tab cache
   示例4: 列出某个路由表的内容
     # ip route ls table fddi153

   示例5: 列出默认路由表的内容
     # ip route ls
 这个命令等于传统的: route

7.9.ip route flush — 擦除路由表
   示例1: 删除路由表main中的所有网关路由(示例:在路由监控程序挂掉之后):
     # ip -4 ro flush scope global type unicast
   示例2:清除所有被克隆出来的IPv6路由:
      # ip -6 -s -s ro flush cache
   示例3: 在gated程序挂掉之后,清除所有的BGP路由:
      # ip -s ro f proto gated/bgp
   示例4: 清除所有ipv4路由cache
      # ip route flush cache
     *** IPv4 routing cache is flushed.

7.10 ip route get — 获得单个路由 .缩写:get、g
    使用这个命令可以获得到达目的地址的一个路由以及它的确切内容。
    ip route get命令和ip route show命令执行的操作是不同的。ip route show命令只是显示现有的路由,而ip route get命令在必要时会派生出新的路由。
   示例1: 搜索到193.233.7.82的路由
      # ip route get 193.233.7.82
      193.233.7.82 dev eth0 src 193.233.7.65 realms inr.ac cache mtu 1500 rtt 300
   示例2: 搜索目的地址是193.233.7.82,来自193.233.7.82,从eth0设备到达的路由(这条命令会产生一条非常有意思的路由,这是一条到193.233.7.82的回环路由)
      # ip r g 193.233.7.82 from 193.233.7.82 iif eth0
        193.233.7.82 from 193.233.7.82 dev eth0 src 193.233.7.65 realms inr.ac/inr.ac
        cache ; mtu 1500 rtt 300 iif eth0
—————————
8. ip route — 路由策略数据库管理命令
       命令  add、delete、show(或者list)
   注意:策略路由(policy routing)不等于路由策略(rouing policy)。
   在某些情况下,我们不只是需要通过数据包的目的地址决定路由,可能还需要通过其他一些域:源地址、IP协议、传输层端口甚至数据包的负载。
   这就叫做:策略路由(policy routing)。
  
8.5. ip rule add — 插入新的规则
ip rule delete — 删除规则
缩写:add、a;delete、del、d

   示例1: 通过路由表inr.ruhep路由来自源地址为192.203.80/24的数据包
  ip ru add from 192.203.80/24 table inr.ruhep prio 220

   示例2:把源地址为193.233.7.83的数据报的源地址转换为192.203.80.144,并通过表1进行路由
  ip ru add from 193.233.7.83 nat 192.203.80.144 table 1 prio 320

   示例3:删除无用的缺省规则
      ip ru del prio 32767

8.7. ip rule show — 列出路由规则
缩写:show、list、sh、ls、l
示例1: # ip ru ls
  0:   from all lookup local
  32762: from 192.168.4.89 lookup fddi153
  32764: from 192.168.4.88 lookup fddi153
  32766: from all lookup main
  32767: from all lookup 253
—————————
9. ip maddress — 多播地址管理
    缩写:show、list、sh、ls、l
9.3.ip maddress show — 列出多播地址
    示例1: # ip maddr ls dummy

9.4. ip maddress add — 加入多播地址
   ip maddress delete — 删除多播地址
   缩写:add、a;delete、del、d
   使用这两个命令,我们可以添加/删除在网络接口上监听的链路层多播地址。这个命令只能管理链路层地址。

    示例1: 增加   # ip maddr add 33:33:00:00:00:01 dev dummy
    示例2: 查看   # ip -O maddr ls dummy
           2: dummy
           link 33:33:00:00:00:01 users 2 static
           link 01:00:5e:00:00:01
    示例3: 删除   # ip maddr del 33:33:00:00:00:01 dev dummy
—————————
10.ip mroute — 多播路由缓存管理

10.4. ip mroute show — 列出多播路由缓存条目
   缩写:show、list、sh、ls、l

   示例1:查看 # ip mroute ls
(193.232.127.6, 224.0.1.39)   Iif: unresolved
(193.232.244.34, 224.0.1.40)   Iif: unresolved
(193.233.7.65, 224.66.66.66)   Iif: eth0    Oifs: pimreg
   示例2:查看 # ip -s mr ls 224.66/16
(193.233.7.65, 224.66.66.66)   Iif: eth0    Oifs: pimreg
9383 packets, 300256 bytes
—————————
11. ip tunnel — 通道配置
   缩写 tunnel、tunl

11.4.ip tunnel add — 添加新的通道
   ip tunnel change — 修改现有的通道
   ip tunnel delete — 删除一个通道
   缩写:add、a;change、chg;delete、del、d
   示例1:建立一个点对点通道,最大TTL是32
     # ip tunnel add Cisco mode sit remote 192.31.7.104 local 192.203.80.1 ttl 32

11.4.ip tunnel show — 列出现有的通道
   缩写:show、list、sh、ls、l
    示例1: # ip -s tunl ls Cisco
—————————
12. ip monitor和rtmon — 状态监视
  ip命令可以用于连续地监视设备、地址和路由的状态。这个命令选项的格式有点不同,命令选项的名字叫做monitor,接着是操作对象:
   ip monitor [ file FILE ] [ all | OBJECT-LIST ]
   示例1: # rtmon file /var/log/rtmon.log
   示例2: # ip monitor file /var/log/rtmon.log r

Linux常用命令集

Standard

常用的基本命令
uname -a 查看内核版本
ls -al 显示所有文件的属性
pwd 显示当前路径
cd – 返回上一次目录 cd ~ 返回主目录
date s 设置时间、日期
cal 显示日历 cal 2006
bc 计算器具
man & info 帮助手册
locale 显示当前字体 locale -a 所有可用字体 /etc/sysconfig/i18n设置文件
LANG=en 使用英文字体
sync 将数据同步写入硬盘
shutdonw -h now & half & poweroff 关机
reboot 重启
startx & init 5 进入图形介面
/work & ?work 向上、下查找文档内容
chgrp 改变档案群组 chgrp testing install.log
chown 改变所属人 chown root:root install.log
chmod 改变属性 chmod 777 install.log read=4 write=2 execute=1
cp 复制 cp filename
rm 删除文件 rm -rf filename 强制删除文件
rmdir 删除文件夹
mv 移动 mv 123.txt 222.txt 重命名
mkdir 创建文件夹
touch 创建文件 更新当前时间
cat 由第一行开始显示 cat |more 分页
nl 在内容前加行号
more & less 一面一面翻动
head -n filename 显示第N行内容
tail -n filename 显示后N行内容
od 显示非纯文档
df -h 显示分区空间
du 显示目录或文件的大小
fdisk 分区设置 fdisk -l /dev/hda 显示硬盘分区状态
mkfs 建立各种文件系统 mkfs -t ext3 /dev/ram15
fsck 检查和修复LINUX档案
ln 硬链接 ln -s 软件链接
whereis 查找命令
locate 查找
find 查找 find / -name “***.***”
which 查看工具
whoami 显示当前用户
gcc -v 查看GCC版本
chattr +i filename 禁止删除 chattr -i filename 取消禁止
lsattr 显示隐藏档属性
updatedb 更新资料库
mke2fs 格式化 mkfs -t ext3
dd if=/etc/passwd of=/tmp/passwd.bak 备份
mount 列出系统所有的分区
mount -t iso9660 /dev/cdrom /mnt/cdrom 挂载光盘
mount -t vfat /dev/fd0 /mnt/floppy 挂载软盘
mount -t vfat -o iocharset=utf8,umask=000 /dev/hda2 /mnt/hda2 挂载fat32分区
mount -t ntfs -o nls=utf8,umask=000 /dev/hda3 /mnt/hda3 挂载ntfs分区
Linux-NTFS Project: http://linux-ntfs.sourceforge.net/
umount /mnt/hda3 缷载
ifconfig 显示或设置网络设备
service network restart 重启网卡
ifdown eth0 关闭网卡
ifup eth0 开启网卡
clear 清屏
history 历史记录 !55 执行第55个指令
stty 设置终端 stty -a
fdisk /mbr 删除GRUB
at 僅進行一次的工作排程
crontab 循環執行的例行性命令 [e]编辑,[l]显示,[r]删除任务
& 后台运行程序 tar -zxvf 123.tar.gz & ———>后台运行
jobs 观看后台暂停的程序 jobs -l
fg 将后台程序调到前台 fg n ——>n是数字,可以指定进行那个程序
bg 让工作在后台运行
kill 结束进程 kill -9 PID [9]强制结束,[15]正常结束,[l]列出可用的kill信号
ps aux 查看后台程序
top 查看后台程序 top -d 2 每两秒更新一次 top -d 2 -p10604 观看某个PID
top -b -n 2 > /tmp/top.txt —–>將 top 的資訊進行 2 次,然後將結果輸出到 /tmp/top.txt
pstree 以树状图显示程序 [A]以 ASCII 來連接, [u]列出PID, [p]列出帐号
killall 要刪除某個服務 killall -9 httpd
free 显示内存状态 free -m ——–>以M为单位显示
uptime 显示目前系统开机时间
netstat 显示网络状态 netstat -tulnp——>找出目前系統上已在監聽的網路連線及其 PID
dmesg 显示开机信息 demsg | more
nice 设置优先权 nice -n -5 vi & —–>用 root 給一個 nice 植為 -5 ,用於執行 vi
renice 调整已存在优先权
runlevel 显示目前的runlevel
depmod 分析可载入模块的相依性
lsmod 显示已载入系统的模块
modinfo 显示kernel模块的信息
insmod 载入模块
modprobe 自动处理可载入模块
rmmod 删除模块
chkconfig 检查,设置系统的各种服务 chkconfig –list —–>列出各项服务状态
ntsysv 设置系统的各种服务
cpio 备份文件

压缩命令
*.Z compress 程式壓縮的檔案;
*.bz2 bzip2 程式壓縮的檔案;
*.gz gzip 程式壓縮的檔案;
*.tar tar 程式打包的資料,並沒有壓縮過;
*.tar.gz tar 程式打包的檔案,其中並且經過 gzip 的壓縮
compress filename 压缩文件 加[-d]解压 uncompress
gzip filename 压缩 加[-d]解压 zcat 123.gz 查看压缩文件内容
bzip2 -z filename 压缩 加[-d]解压 bzcat filename.bz2 查看压缩文件内容
tar -cvf /home/123.tar /etc 打包,不压缩
tar -xvf 123.tar 解开包
tar -zxvf /home/123.tar.gz 以gzip解压
tar -jxvf /home/123.tar.bz2 以bzip2解压
tar -ztvf /tmp/etc.tar.gz 查看tar内容
cpio -covB > [file|device] 份份
cpio -icduv < [file|device] 还原

vi一般用法
一般模式 编辑模式 指令模式
h 左 a,i,r,o,A,I,R,O :w 保存
j 下 进入编辑模式 :w! 强制保存
k 上 dd 删除光标当前行 :q! 不保存离开
l 右 ndd 删除n行 :wq! 保存后离开
0 移动到行首 yy 复制当前行 :e! 还原原始档
$ 移动到行尾 nyy 复制n行 :w filename 另存为
H 屏幕最上 p,P 粘贴 :set nu 设置行号
M 屏幕中央 u 撤消 :set nonu 取消行号
L 屏幕最下 [Ctrl]+r 重做上一个动作 ZZ 保存离开
G 档案最后一行 [ctrl]+z 暂停退出 :set nohlsearch 永久地关闭高亮显示
/work 向下搜索 :sp 同时打开两个文档
?work 向上搜索 [Ctrl]+w 两个文档设换
gg 移动到档案第一行 :nohlsearch 暂时关闭高亮显示

帐号管理
/etc/passwd 系统帐号信息
/etc/shadow 帐号密码信息 经MD5 32位加密
在密码栏前面加『 * 』『 ! 』禁止使用某帐号
/etc/group 系统群组信息
/etc/gshadow
newgrp 改变登陆组
useradd & adduser 建立新用户 ———> useradd -m test 自动建立用户的登入目录
useradd -m -g pgroup test ———>指定所属级
/etc/default/useradd 相关设定
/etc/login.defs UID/GID 有關的設定
passwd 更改密码 ———–> passwd test
usermod 修改用户帐号
userdel 删除帐号 ———–>userdel -r test
chsh 更换登陆系统时使用的SHELL [-l]显示可用的SHELL;[-s]修改自己的SHELL
chfn 改变finger指令显示的信息
finger 查找并显示用户信息
id 显示用户的ID ———–> id test
groupadd 添加组
groupmod 与usermod类似
groupdel 删除组
su test 更改用户 su – 进入root,且使用root的环境变量
sudo 以其他身份来执行指令
visudo 编辑/etc/sudoers 加入一行『 test ALL=(ALL) ALL 』
%wheel ALL = (ALL) ALL 系统里所有wheel群组的用户都可用sudo
%wheel ALL = (ALL) NOPASSWD: ALL wheel群组所有用户都不用密码NOPASSWD
User_Alias ADMPW = vbird, dmtsai, vbird1, vbird3 加入ADMPW组
ADMPW ALL = NOPASSWD: !/usr/bin/passwd, /usr/bin/passwd [A-Za-z]*, \
!/usr/bin/passwd root 可以更改使用者密码,但不能更改root密码 (在指令前面加入 ! 代表不可)
PAM (Pluggable Authentication Modules, 嵌入式模組)

who & w 看谁在线
last 最近登陆主机的信息
lastlog 最近登入的時間 读取 /var/log/lastlog
talk 与其他用户交谈
write 发送信息 write test [ctrl]+d 发送
mesg 设置终端机的写入权限 mesg n 禁止接收 mesg y
wall 向所有用户发送信息 wall this is q test
mail 写mail
/etc/default/useradd 家目录默认设置

quota 显示磁盘已使用的空间与限制 quota -guvs —–>秀出目前 root 自己的 quota 限制值
quota -vu 查询
quotacheck 检查磁盘的使用空间与限制 quotacheck -avug —–>將所有的在 /etc/mtab 內,含有 quota 支援的 partition 進行掃瞄
[-m] 强制扫描
quota一定要是独立的分区,要有quota.user和quota.group两件文件,在/etc/fstab添加一句:
/dev/hda3 /home ext3 defaults,usrquota,grpquota 1 2
chmod 600 quota* 设置完成,重启生效
edquota 编辑用户或群组的quota [u]用户,[g]群组,[p]复制,[t]设置宽限期限
edquota -a yang edquota -p yang -u young —–>复制
quotaon 开启磁盘空间限制 quotaon -auvg ——–>啟動所有的具有 quota 的 filesystem
quotaoff 关闭磁盘空间限制 quotaoff -a ——–>關閉了 quota 的限制
repquota -av 查閱系統內所有的具有 quota 的 filesystem 的限值狀態

Quota 從開始準備 filesystem 的支援到整個設定結束的主要的步驟大概是:
1、設定 partition 的 filesystem 支援 quota 參數:
由於 quota 必須要讓 partition 上面的 filesystem 支援才行,一般來說, 支援度最好的是 ext2/ext3 ,
其他的 filesystem 類型鳥哥我是沒有試過啦! 啟動 filesystem 支援 quota 最簡單就是編輯 /etc/fstab ,
使得準備要開放的 quota 磁碟可以支援 quota 囉;
2、建立 quota 記錄檔:
剛剛前面講過,整個 quota 進行磁碟限制值記錄的檔案是 aquota.user/aquota.group,
要建立這兩個檔案就必須要先利用 quotacheck 掃瞄才行喔!
3、編輯 quota 限制值資料:
再來就是使用 edquota 來編輯每個使用者或群組的可使用空間囉;
4、重新掃瞄與啟動 quota :
設定好 quota 之後,建議可以再進行一次 quotacheck ,然後再以 quotaon 來啟動吧!

开机流程简介
1、載入 BIOS 的硬體資訊,並取得第一個開機裝置的代號;
2、讀取第一個開機裝置的 MBR 的 boot Loader (亦即是 lilo, grub, spfdisk 等等) 的開機資訊;
3、載入 Kernel 作業系統核心資訊, Kernel 開始解壓縮,並且嘗試驅動所有硬體裝置;
4、Kernel 執行 init 程式並取得 run-level 資訊;
5、init 執行 /etc/rc.d/rc.sysinit 檔案;
6、啟動核心的外掛模組 (/etc/modprobe.conf);
7、init 執行 run-level 的各個批次檔( Scripts );
8、init 執行 /etc/rc.d/rc.local 檔案;
9、執行 /bin/login 程式,並等待使用者登入;
10、登入之後開始以 Shell 控管主機。
在/etc/rc.d/rc3.d內,以S开头的为开机启动,以K开头的为关闭,接着的数字代表执行顺序
GRUB vga设定
彩度\解析度 640×480 800×600 1024×768 1280×1024 bit
256 769 771 773 775 8 bit
32768 784 787 790 793 15 bit
65536 785 788 791 794 16 bit
16.8M 786 789 792 795 32 bit

./configure 检查系统信息 ./configure –help | more 帮助信息
make clean 清除之前留下的文件
make 编译
make install 安装
rpm -q —–>查询是否安装 rpm -ql ——>查询该套件所有的目录
rpm -qi —–>查询套件的说明资料 rpm -qc[d] —–>设定档与说明档
rpm -ivh —->安装 rpm -V ——–>查看套件有否更动过
rpm -e ——>删除 rpm -Uvh ——->升级安装
–nodeps —–>强行安装 –test —–>测试安装

转自:ChinaUnix